Home > Support > Is Quicken for Mac Compatible with Mac OS 10.7 Lion?

Is Quicken for Mac Compatible with Mac OS 10.7 Lion?

Updated: 5/11/2012 | Article ID: GEN83208

Will Quicken for Mac 2005, 2006, or 2007 work on the latest Apple operating system, OS X 10.7 Lion?

Quicken for Mac 2005, 2006 or 2007 will not work on Lion. However, Lion-compatible Quicken Mac 2007 is now available.

Quicken Essentials for Mac will still continue to work on OS X 10.6 Snow Leopard or later, including Lion. If you are using Quicken Essentials, make sure you are on the latest Quicken Essentials patch version for full compatibility.

Why will Quicken for Mac 2005, 2006, or 2007 not work on OS X 10.7 Lion?

Quicken for Mac 2005, 2006 and 2007 were originally built for the older PowerPC architecture, and were able to run on newer Intel-based Macs due to an Apple technology called Rosetta. As of OS X 10.7, Apple has discontinued support for Rosetta. Lion Compatible Quicken Mac 2007 is a re-engineered version of Quicken for Mac 2007 that will work on OS X 10.7 Lion.

What are my options if I don't upgrade to OS X 10.7 Lion?

If you do not plan on upgrading to OS X 10.7 Lion, no action is required. You can continue using Quicken for Mac 2005, 2006 or 2007 as is.

What are your plans related to personal finance solutions for Apple customers?

We are committed to supporting Apple products and our Mac customers. We are actively working on a personal finance solution for the iPad, as well as continuing to deliver the highly rated Mint.com iPhone application. In addition, we are evaluating options for Quicken Essentials for Mac.

 
Community Discussions

Share advice with other Quicken customers about using our products and managing your finances.

Quicken Community
Still Haven't Solved It?
Did this article help you?
Content Article Feedback