Home > Support > Error When Converting File: "Can't open file", "Unable to validate data file", or "Unable to open file"

Error When Converting File: "Can't open file", "Unable to validate data file", or "Unable to open file"

Updated: 4/27/2012 | Article ID: GEN82031

Overview

You may receive one of the following errors when converting data:

  • Can't open file
  • Unable to validate data file
  • Unable to open file

Cause

These errors may occur if:

  • The file you are converting has a file path that exceeds 39 characters (Windows XP).
  • The filename used in Quicken is longer than eight characters (Windows XP).
  • Your Quicken data may have damage that occurred in the previous version of Quicken, which would need to be repaired before converting to the current version.

Instructions

To resolve this issue, you will first need to determine the length of the file path or filename:

  1. Start Quicken while pressing the Ctrl key on your keyboard. This starts Quicken without a data file. 
  2. Click on the File menu and at the bottom of this menu is a list of recently used files. Review the list for paths and filenames.

If the file path exceeds 39 characters:

  1. Create a new folder with a shorter path to store your Quicken data files in (for Example C:\QknData). To do this:
    1. Right-click the Microsoft® Windows® Start button, and choose Explorer.
    2. Select the C:\ drive or the appropriate drive letter where Quicken is installed.
    3. From the Windows Explorer File menu, choose New, and then choose Folder. Enter the name for the new folder.
  2. In Windows Explorer, copy all of the original data files to the new folder created in step 1:
    1. If you are not certain where the files are located, search for all files that end with the following extensions: .qdf, .qsd, .qph, .qel. You will need all of these files to access your Quicken data.
    2. Click each file you found in step 2a while pressing Ctrl to select all files.
    3. From the Windows Explorer Edit menu, choose Copy.
    4. Open the C:\QKNData or new folder that you created in step 1.
    5. From the Edit menu, choose Paste to copy your data files into the new folder.
    6. Repeat steps 2a through 2e as necessary for each file you need to copy.
  3. Double-click the Quicken icon on your Desktop while pressing Ctrl + Shift to open Quicken without a data file.
  4. From the Quicken File menu, choose Open and browse to the location created for the Quicken data in step 1. Select the appropriate data file in this location and select OK.

If the Quicken filename is longer than eight characters or contains special characters such as spaces, dashes, or dollar symbols:

    In versions of Quicken prior to 2010, you were able to rename your Quicken data file with in the software. In Quicken 2010 and newer, to rename the Quicken data file you will need to go to the location where the data file is located on your system. Once you find the file, to rename the file, right-click on the file name and select rename, type a new name for the data file (8 characters or less, without spaces, dashes or the use of the dollar symbol), then press enter on your keyboard.

If your data file was converted to a higher version of Quicken then you will receive the error: Unable to validate data file.

  • Follow the directions here to restore a prior version of your data file.

If none of the above applied, your Quicken data may have minor damage that occurred in the earlier version of Quicken. The data damage needs to be repaired before converting to the current version.

To repair the data damage:

  1. Uninstall the new version of Quicken.
  2. Reinstall the older version of Quicken.
  3. Restore a recent backup that is in the previous version's format.
  4. Correct the data damage.
  5. Reinstall the new version of Quicken, and then convert the file.

 

 
Community Discussions

Share advice with other Quicken customers about using our products and managing your finances.

Quicken Community
Still Haven't Solved It?
Did this article help you?
Content Article Feedback